Jump to content

Rust NO KOS - Noob Friendly server!

With the recent boom in players swarming to Rust, we have decided to launch a rust server that caters to newer and returning players. This is a Limited PVP server with rules in place to help remove the toxicity that you see in most Rust servers. Come give it a try!
Our Servers Rust Rules

King of the Hill

King of the Hill is a three team sector control mission within ArmA 3. As you play you will gain experience which will in turn unlock new gear and vehicles to aid your teams efforts to control the zone.
Our Servers

King of the Hill: RHS

RHS King of the Hill is a version that combines the popular RHS mod with KotH. In this version of the award winning sector control mission you play as Nato or Russian forces. Just like in vanilla KotH you will gain experience by playing which will in turn unlock new gear and vehicles to aid your teams efforts to control the zone. RHS and vanilla stats are separately saved in our database and are displayed here: https://stats.armakoth.com
Our Servers

Having trouble joining RHS servers

Recommended Posts

I followed the links provided in other posts like https://codefourgaming.com/forums/topic/2791-cannot-play-on-the-rhs-server/

I have everything downloaded and turned on that's required, yet I still get  errors with RHSSAF and "are not signed by a key accepted by this server. to play on this server removed the listed files or install addition accepted keys"

Not sure why I'm getting this but it's a bit of a bummer. I attached photos of the error, the mod tray in the main menu showing everything on and the workshop collection you normally link to show that I have everything downloaded too.

subscribed list.PNG

loaded mods.PNG


Link to post
Share on other sites
  • 5 months later...
Guest dodget90

did you ever fix this , im having same problem , i have the exact same files and keys , i downloaded them on my client then copied them over to my server , still no good

Link to post
Share on other sites
  • 5 months later...
  • 3 weeks later...
Guest Mikeslefthand

I'm having the same issue as well and it's been ongoing for almost a year now. There is no information or fix on arma 3 related site that I can find 



Link to post
Share on other sites
  • 4 weeks later...
Guest Guest R.A

I found a solution that has worked for myself.
Inside the folder Steam/steamapps/common/Arma 3/!Workshop/@RHSSAF/addons as the issue was with RHSSAF files for me, there were two versions of the .bisign files below most .pbo files.
One of the files was for the 0.5.0 version and one for the 0.5.4 version.
After removing the 0.5.0 version below each of the .pbo files I was able to join the server.

My guess would be that the server checked the old version first as it is alphabetically above the newer one and returned an error immediately.

Link to post
Share on other sites
  • 6 months later...

Hi guys,


I have the same issue, i've tried all the solutions up and nothing work. Can you please help us, a lot of us out there are having the same problem.


Thanks in advance.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...